报错原因

JDK版本和IDEA设置的级别不同导致的

解决方法

  1. 打开项目结构
  2. 查看你的JDK版本(我的是1.8)
  3. 设置项目语言级别和你的JDK版本一致

原文链接:https://miansen.wang/2018/09/11/4/